File downloads not accessible
Incident Report for Mast
Resolved
A fix has been deployed and this incident is resolved.
Posted Mar 13, 2023 - 12:47 GMT
Identified
We're aware of an issue downloading files from the Mast platform. We've identified the issue and a fix should be live shortly.
Posted Mar 13, 2023 - 11:54 GMT
This incident affected: Mast Platform.